GeekSpy Forums
https://geekspy.net/forums/

Issues with posting...
https://geekspy.net/forums/viewtopic.php?f=4&t=80
Page 2 of 2

Author:  Cyrris [ Sep 22, 13 - 12:00 PM ]
Post subject:  Re: Issues with posting...

OK, account created and email sent!

Author:  TheeGoatPig [ Sep 22, 13 - 3:18 PM ]
Post subject:  Re: Issues with posting...

Still didn't work. I have no topic creation privileges.

Author:  Cyrris [ Sep 22, 13 - 8:16 PM ]
Post subject:  Re: Issues with posting...

When you said the result was the same from home or from work, how different is your work environment?

Completely different computer, or bringing a laptop from home so only the network is different?

Author:  TheeGoatPig [ Sep 22, 13 - 9:11 PM ]
Post subject:  Re: Issues with posting...

In Reply To #18

Completely different computer. They are both Windows 7, but that is the end of the similarities.

Author:  Cyrris [ Sep 22, 13 - 9:42 PM ]
Post subject:  Re: Issues with posting...

Right. Here's what I've found.

It seems my web host has implemented a particularly aggressive form of user-input filtering at the Apache web server level. I don't know how long they've been doing it, but since GeekSpy was only moved on to this host a few weeks ago, it explains why the problem only cropped up when it did.

Currently it is not possible to submit a form on this site (regardless of whether we are a forum, a blog, whatever the site software) if any data in the form contains the words "poker" or other trigger words. Goaty was simply trying to post about his upcoming tournament, which I expect we'll all read about shortly. A bit of testing shows "viagra" is also a trigger word, while "cialis" is not. I didn't bother testing further. The reason I can post those words is because I've sprinkled them with BBcode so they're not detected.

So, I've contacted the web host to have the word blocks removed. While it might be appropriate to block certain spam keywords for WordPress blogs (it helps prevent CPU load if a blog is getting spammed a lot), it's not at all appropriate for a forum like this one.

Author:  Cyrris [ Sep 23, 13 - 5:53 PM ]
Post subject:  Re: Issues with posting...

The web host has removed the blocks, Goaty. Over to you.

Author:  TheeGoatPig [ Sep 23, 13 - 6:29 PM ]
Post subject:  Re: Issues with posting...

Wow! It worked! thanks Chris, for all the help :grin:

Though I'm not sure if I really care about the topic anymore... :wink:

Author:  Cyrris [ Sep 23, 13 - 6:39 PM ]
Post subject:  Re: Issues with posting...

In Reply To #22

Well regardless, I'm glad I got to the bottom of it. Gives me a slightly better understanding of how such things work.

Page 2 of 2 All times are UTC [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/